Forum

Weird Networking Pr...
 
Notifications
Clear all

Question Weird Networking Problem with Foundry Self-Host

   RSS

0
Topic starter

I've been self-hosting Foundry for two years using a windows box running node.js. This pc is used only as a server. I haven't had any problems over the last two years and moved to using SSH for video and chat about six months ago without problem. I'm running Foundry V9 with the most recent stable release.

About a month ago, after powering down the server pc for mainenance my player (I only have one) could not log into the server. It would just hang and if he tried to log in again, it would say 'This site can't be reached'. We tried a bunch of things (rebooting machines, restarting chrome, rebooting cable modem and router, etc). I could log in from other computers on my lan without issue; but when I put them on wifi hotspot they wouldn't work. After hours of struggle we gave up and our weekly session was lost. The next day he told me that he discovered his machine had successfully logged in over night. I tested my machines with mobile hotspot and they all logged in as if nothing had happened. One thing I noticed when I watched the Foundry server command terminal after I power cycled the modem and router, once the network was back up one of the hotspot machines (which would not have lost internet during the power cycle) had a client session created and logging in. An aggravating mystery, but life and game went on. I asked about this on the Foundry Discord but no one with networking skills was on and I was never able to get anyone to respond.

On Friday, since things had been going well, I did maintenance on the server again. I didn't really need to and definitely shouldn't have so close to our weekly session. The problem re-arose and another weekly session was lost. This time we were watching on Console(F12) to see what was happening and I was monitoring my router to see if the non-local machines were trying to access the server. The remote machines were definitely reaching the server pc and sometimes would get something on the browser that said Foundry V9. Try as we may we could never get it across the finish line. Sometimes most of the load screen would be there before it would timeout. We thought maybe it was trying to buffer content, albeit slowly. The next day my mobile hotspot machine was able to log in again and still is. My player's pc doesn't seem any closer. I've been working with a remote machine that I have at my parents that I can teamview into and I haven't been able to get it going yet, but it has gotten close as well. 

It seems unlikely that I'm the only one that has these problems, but maybe so. I hope someone has an idea what is going wrong. Thanks.

Share: